Supported Platforms Matrix

The operating system and processor combinations - for which Iometer is known to compile and work - are named in the following list. Please notice, that this list covers the Dynamo part only. The GUI itself is available for Windows on IA32 / IA64 only!

2003.12.16
IA32 IA64 SPARC
Linux Debian 3.0 (2.4.18 kernel, gcc 2.95.4, glibc 2.2.5),
Red Hat 9 (2.4.20 kernel, gcc 3.2, glibc 2.3.2 with NPTL)*,
Red Hat 8.0 (2.4.18 kernel, gcc 3.2, glibc 2.2.93),
Red Hat 7.2 (2.4.7 kernel, gcc 2.96, glibc 2.2.5),
SuSE 8.1 (2.4.19 kernel, gcc 3.2, glibc 2.2.5),
SuSE 7.3 (2.4.10 kernel, gcc 2.95.3, glibc 2.2.4)
not supported not supported
Solaris unknown not supported Solaris 8 (gcc 2.95.3)
Windows Windows XP Pro (MSVC++ .NET),
Windows 2000 (MSVC++ 6.0),
Windows NT 4 (MSVC++ 6.0)
should work not supported

List of known combinations for version 2003.12.16 ("should work" means, that this combination is expected to work, but wasn't confirmed till now).
* = To get the job done, please consult the Know Issues page [here] first!

2003.05.10
IA32 IA64 SPARC
Linux Debian 3.0 (2.4.18 kernel, gcc 2.95.4, glibc 2.2.5),
Red Hat 9 (2.4.20 kernel, gcc 3.2, glibc 2.3.2 with NPTL)*,
Red Hat 8.0 (2.4.18 kernel, gcc 3.2, glibc 2.2.93),
Red Hat 7.2 (2.4.7 kernel, gcc 2.96, glibc 2.2.5),
SuSE 8.1 (2.4.19 kernel, gcc 3.2, glibc 2.2.5),
SuSE 7.3 (2.4.10 kernel, gcc 2.95.3, glibc 2.2.4)
not supported not supported
Solaris unknown not supported Solaris 8 (gcc 2.95.3)
Windows Windows XP Pro (MSVC++ .NET),
Windows 2000 (MSVC++ 6.0),
Windows NT 4 (MSVC++ 6.0)
should work not supported

List of known combinations for version 2003.05.10 ("should work" means, that this combination is expected to work, but wasn't confirmed till now).
* = To get the job done, please consult the Know Issues page [here] first!

2003.02.15
IA32 IA64 SPARC
Linux Red Hat 8.0 (2.4.18 kernel, gcc 3.2),
Red Hat 7.2 (2.4.7 kernel, gcc 2.96),
SuSE 8.1 (2.4.19 kernel, gcc 3.2),
SuSE 7.3 (2.4.10 kernel, gcc 2.95.3)
not supported not supported
Solaris unknown not supported should work
Windows Windows 2000 (MSVC++ 6.0),
Windows NT 4 (MSVC++ 6.0)
should work not supported

List of known combinations for version 2003.02.15 ("should work" means, that this combination is expected to work, but wasn't confirmed till now).

2003.02.08
IA32 IA64 SPARC
Linux Red Hat 7.2 (2.4.7 kernel, gcc 2.96),
SuSE 7.3 (2.4.10 kernel, gcc 2.95.3)
not supported not supported
Solaris unknown not supported Solaris 8 (gcc 2.95.3)
Windows Windows 2000 (MSVC++ 6.0) should work not supported

List of known combinations for version 2003.02.08 ("should work" means, that this combination is expected to work, but wasn't confirmed till now).